using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\]\&\[)(\d+-\d+)";
string input = @"[Test].Test Stuff].[Class].&[002 - My Hat]&[002-01 - Big Hat]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}