re = /(?<=\]\&\[)(\d+-\d+)/
str = '[Test].Test Stuff].[Class].&[002 - My Hat]&[002-01 - Big Hat]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end