$re = '/(?<=\]\&\[)(\d+-\d+)/';
$str = '[Test].Test Stuff].[Class].&[002 - My Hat]&[002-01 - Big Hat]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);