import Foundation
let pattern = #"\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\"(.*)\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
*e UserInterface Extensions Event Changed Signal: "togglebutton:on"
*e UserInterface Extensions Event Changed Signal: "togglebutton:off"
*e UserInterface Extensions Event Pressed Signal: "slider"
*e UserInterface Extensions Event Changed Signal: "slider:32"
*e UserInterface Extensions Event Changed Signal: "slider:68"
*e UserInterface Extensions Event Released Signal: "slider:68"
*e UserInterface Extensions Event Pressed Signal: "spinner:decrement"
*e UserInterface Extensions Event Released Signal: "spinner:decrement"
*e UserInterface Extensions Event Clicked Signal: "spinner:decrement"
*e UserInterface Extensions Event Pressed Signal: "button"
*e UserInterface Extensions Event Released Signal: "button"
*e UserInterface Extensions Event Clicked Signal: "button"
*e UserInterface Extensions Event Pressed Signal: "symbol"
*e UserInterface Extensions Event Released Signal: "symbol"
*e UserInterface Extensions Event Clicked Signal: "symbol"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)