using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?=(\([\w\/]+\)|[\w\/]))\2)+)";
string input = @"I am a robot, I have been named 456/m(4) 456/m(4). Forget the name (it does not mean anything) exposed to 360J/m(2) and 456/m(4)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}