import Foundation
let pattern = #"((?:(?=(\([\w\/]+\)|[\w\/]))\2)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I am a robot, I have been named 456/m(4) 456/m(4). Forget the name (it does not mean anything) exposed to 360J/m(2) and 456/m(4)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)