$re = '/((?:(?=(\([\w\/]+\)|[\w\/]))\2)+)/';
$str = 'I am a robot, I have been named 456/m(4) 456/m(4). Forget the name (it does not mean anything) exposed to 360J/m(2) and 456/m(4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);