const regex = new RegExp('<b>Location:\\s*</b>\\s*([^<]*)', 'g')
const str = `<div class="FindBoxTopL fl_left">
<b>Salary: </b> \$10.00 <br>
<b>Location: </b> Wisconsin Madison<br>
<b>Country:</b>United States<br>
<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}