// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<b>Location:\s*</b>\s*([^<]*)").unwrap();
let string = "<div class=\"FindBoxTopL fl_left\">
<b>Salary: </b> $10.00 <br>
<b>Location: </b> Wisconsin Madison<br>
<b>Country:</b>United States<br>
<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}