use strict;
my $str = '<div class="FindBoxTopL fl_left">
<b>Salary: </b> $10.00 <br>
<b>Location: </b> Wisconsin Madison<br>
<b>Country:</b>United States<br>
<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>
</div>';
my $regex = qr~<b>Location:\s*</b>\s*([^<]*)~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}