const regex = /^(?:(?:(?:(\d+)d\s*)?((\d+)h\s*)?)?(\d+)m\s*)?((\d+)s)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:(\\d+)d\\s*)?((\\d+)h\\s*)?)?(\\d+)m\\s*)?((\\d+)s)?$', 'gm')
const str = `1d 2h 3m 4s
1h 2m 3s
1m 2s
1s
1d2h3m4s
1h2m3s
1m2s
1s
15m
1d 3m`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);