re = /^(?:(?:(?:(\d+)d\s*)?((\d+)h\s*)?)?(\d+)m\s*)?((\d+)s)?$/m
str = '1d 2h 3m 4s
1h 2m 3s
1m 2s
1s
1d2h3m4s
1h2m3s
1m2s
1s
15m
1d 3m'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result