# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:(\d+)d\s*)?((\d+)h\s*)?)?(\d+)m\s*)?((\d+)s)?$"
test_str = ("1d 2h 3m 4s\n"
"1h 2m 3s\n"
"1m 2s\n"
"1s\n"
"1d2h3m4s\n"
"1h2m3s\n"
"1m2s\n"
"1s\n"
"15m\n"
"1d 3m")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.