package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<img .*?>)`)
var str = `hey how are you <img src="example.com/image.png"> test test <img src="example.com/image2.png">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}