$re = '/(<img .*?>)/';
$str = 'hey how are you <img src="example.com/image.png"> test test <img src="example.com/image2.png">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);