re = /(<img .*?>)/
str = 'hey how are you <img src="example.com/image.png"> test test <img src="example.com/image2.png">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end