package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?ChangePack-[a-zA-Z0-9]+)`)
var str = `/Repository/Framework/PITA/branches/ChangePack-6a7B6/core/src/Pita.x86.Interfaces/IDemoReader.cs
/Repository/Demo1/Demo2/4.3//PITA/branches/ChangePack-6a7B6/core/src/Pita.x86.Interfaces
/Repository/Framework/ChangePack-7/branches/ChangePack-6a7B6/hh1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}