const regex = /^(.*?ChangePack-[a-zA-Z0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?ChangePack-[a-zA-Z0-9]+)', 'gm')
const str = `/Repository/Framework/PITA/branches/ChangePack-6a7B6/core/src/Pita.x86.Interfaces/IDemoReader.cs
/Repository/Demo1/Demo2/4.3//PITA/branches/ChangePack-6a7B6/core/src/Pita.x86.Interfaces
/Repository/Framework/ChangePack-7/branches/ChangePack-6a7B6/hh1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}