re = /^(.*?ChangePack-[a-zA-Z0-9]+)/m
str = '/Repository/Framework/PITA/branches/ChangePack-6a7B6/core/src/Pita.x86.Interfaces/IDemoReader.cs
/Repository/Demo1/Demo2/4.3//PITA/branches/ChangePack-6a7B6/core/src/Pita.x86.Interfaces
/Repository/Framework/ChangePack-7/branches/ChangePack-6a7B6/hh1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end