package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^<(?:"[^"]*"|[^>])+>`)
var str = `<html attribute1="<test1>" test2 attribute2="test2"></html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}