$re = '/^<(?:"[^"]*"|[^>])+>/mi';
$str = '<html attribute1="<test1>" test2 attribute2="test2"></html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);