# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$\(\"(.+?)\"\)\.live\(\"(.+?)\""
test_str = (" $(\"form.ajaxForm\").live(\"submit\", function () {\n"
" $(\".button-disable\").live(\"click\", function () {\n"
" $(\".button-toggle\").live(\"click\", function () {\n"
" $(\".button-hidden-setter\").live(\"click\", function () {\n"
"$(\".tool-tip\").live(\"click\", function (event) {\n"
"$(\".tool-tip\").live(\"mouseout\", function (event) {\n")
subst = "$(document).on(\"\\2\",\"\\1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.