const regex = /\/\/.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/.*', 'g')
const str = `// This is a comment
//This is also a comment
// I am a comment with a dot.
{
// No need for space.
}
// Here we do need space.
var x = 2;
// We also need space here.
// This is also a comment.
// This too is a comment.
x = 5; // Treat this as a comment too.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}