use strict;
my $str = '// This is a comment
//This is also a comment
// I am a comment with a dot.
{
// No need for space.
}
// Here we do need space.
var x = 2;
// We also need space here.
// This is also a comment.
// This too is a comment.
x = 5; // Treat this as a comment too.';
my $regex = qr/\/\/.*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}