$re = '/\/\/.*/';
$str = '// This is a comment
//This is also a comment
// I am a comment with a dot.
{
// No need for space.
}
// Here we do need space.
var x = 2;
// We also need space here.
// This is also a comment.
// This too is a comment.
x = 5; // Treat this as a comment too.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);