using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<prevFields>.*)\""PUT\s+\/sendmail\s+HTTP\/\d+\.\d+\""\s+(?<statusFieldStart>\d+\s+\d+\s+\d+)";
string input = @".. [2020-11-26T11:27:56.025047450Z] ""PUT /sendmail HTTP/1.1"" 400 203 252 ""-"" ...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}