import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<prevFields>.*)\\\"PUT\\s+\\/sendmail\\s+HTTP\\/\\d+\\.\\d+\\\"\\s+(?<statusFieldStart>\\d+\\s+\\d+\\s+\\d+)";
final String string = ".. [2020-11-26T11:27:56.025047450Z] \"PUT /sendmail HTTP/1.1\" 400 203 252 \"-\" ...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}