const regex = /(?<prevFields>.*)\"PUT\s+\/sendmail\s+HTTP\/\d+\.\d+\"\s+(?<statusFieldStart>\d+\s+\d+\s+\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<prevFields>.*)\\"PUT\\s+\\\/sendmail\\s+HTTP\\\/\\d+\\.\\d+\\"\\s+(?<statusFieldStart>\\d+\\s+\\d+\\s+\\d+)', 'gm')
const str = `.. [2020-11-26T11:27:56.025047450Z] "PUT /sendmail HTTP/1.1" 400 203 252 "-" ...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}