import re
regex = re.compile(r"(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?", flags=re.MULTILINE)
test_str = "aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")