re = /(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?/m
str = 'aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end