import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(#\\{[a-zA-Z_]+=.*(&[a-zA-Z_]+=.*)*\\})|(\\{\\{.*\\}\\})";
final String string = "#{config_name=Scene&sn={2}&field=name} \n"
+ "#{pos_x={3}&y={4}&z={5}&stage={6}&stageId={7}&content=Go Now&http=true&underline=true} \n"
+ "{{rescue_{1}_{2}_Rescue Now}} ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}