use strict;
my $str = '#{config_name=Scene&sn={2}&field=name}
#{pos_x={3}&y={4}&z={5}&stage={6}&stageId={7}&content=Go Now&http=true&underline=true}
{{rescue_{1}_{2}_Rescue Now}} ';
my $regex = qr/(#\{[a-zA-Z_]+=.*(&[a-zA-Z_]+=.*)*\})|(\{\{.*\}\})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}