$re = '/(#\{[a-zA-Z_]+=.*(&[a-zA-Z_]+=.*)*\})|(\{\{.*\}\})/m';
$str = '#{config_name=Scene&sn={2}&field=name}
#{pos_x={3}&y={4}&z={5}&stage={6}&stageId={7}&content=Go Now&http=true&underline=true}
{{rescue_{1}_{2}_Rescue Now}} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);