package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?([^/]+)/[^/]+$`)
var str = `https://example.com/names/ani/digitalcod-org
https://example.com/names/bmc/ambulancecod.org`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}