re = /.*?([^\/]+)\/[^\/]+$/m
str = 'https://example.com/names/ani/digitalcod-org
https://example.com/names/bmc/ambulancecod.org'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end