package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b|\d)(?:banana|([a-zA-Z]+))(?1)`)
var str = `0827banana82/+wine22green-729
0827bananas82/+wine22green-729
banana82/+wine22green-729`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}