$re = '/(\b|\d)(?:banana|([a-zA-Z]+))(?1)/m';
$str = '0827banana82/+wine22green-729
0827bananas82/+wine22green-729
banana82/+wine22green-729';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);