// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b|\d)(?:banana|([a-zA-Z]+))(?1)").unwrap();
let string = "0827banana82/+wine22green-729
0827bananas82/+wine22green-729
banana82/+wine22green-729";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}