#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:#(\d+(?:,\d+)*)#)? *([^<]+?) *(?:\(([^()]*)\))? *(?:<(\d+(?:,\d+)*)>)?$"
Local $sString = "N-e-1-[(5E)-5,6-e]-4 c" & @CRLF & _
"#312,4# N-e-1-[(5E)-5,6-e]-4 c <5,6,7>" & @CRLF & _
"#1,2,3# {N-e-1-[(5E)-5,6-e]-4 c} (#4,5# comments <6,7>) <8,9,10>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")