re = /^(?:#(\d+(?:,\d+)*)#)? *([^<]+?) *(?:\(([^()]*)\))? *(?:<(\d+(?:,\d+)*)>)?$/m
str = 'N-e-1-[(5E)-5,6-e]-4 c
#312,4# N-e-1-[(5E)-5,6-e]-4 c <5,6,7>
#1,2,3# {N-e-1-[(5E)-5,6-e]-4 c} (#4,5# comments <6,7>) <8,9,10>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end