import re
regex = re.compile(r"^(?:#(\d+(?:,\d+)*)#)? *([^<]+?) *(?:\(([^()]*)\))? *(?:<(\d+(?:,\d+)*)>)?$", flags=re.MULTILINE)
test_str = ("N-e-1-[(5E)-5,6-e]-4 c\n"
"#312,4# N-e-1-[(5E)-5,6-e]-4 c <5,6,7>\n"
"#1,2,3# {N-e-1-[(5E)-5,6-e]-4 c} (#4,5# comments <6,7>) <8,9,10>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")