use strict;
my $str = 'Sun 16
08:00 -
16:00
RTW
Mon 17
08:00 - 16:00
RTW
Tue 18
08:00 -16:00
RTW
Wed 19
08:00 -
16:00
RTW
Thu 20
08:00 - 16:00
RTW
Fri 21
08:00 - 16:00
RTW
Sat 22
OFF
Sun 23
OFF
Mon 24
OFF
Tue 25
04:40 -
13:07
5180
KM+
Wed
26
04:11
-
12:22
5178
Thu 27
10:00 - 18:00
Work.Group
Scheduling &
Rostering 1300-
1500 @Burwood...
Fri 28
OFF
Sat 29
NTA';
my $regex = qr/([A-Za-z]{3}\s[0-9]{1,2})\s?([0-9]{2}:[0-9]{2})?(?:\s?-\s?([0-9]{2}:[0-9]{2}))?\s?.*?(?=\n(Mon|Tue|Wed|Thu|Fri|Sat|Sun)\s[0-9]|$)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}