import re
regex = re.compile(r"([A-Za-z]{3}\s[0-9]{1,2})\s?([0-9]{2}:[0-9]{2})?(?:\s?-\s?([0-9]{2}:[0-9]{2}))?\s?.*?(?=\n(Mon|Tue|Wed|Thu|Fri|Sat|Sun)\s[0-9]|$)", flags=re.DOTALL)
test_str = ("Sun 16\n"
"08:00 -\n"
"16:00\n"
"RTW\n"
"Mon 17\n"
"08:00 - 16:00\n"
"RTW\n"
"Tue 18\n"
"08:00 -16:00\n"
"RTW\n"
"Wed 19\n"
"08:00 -\n"
"16:00\n"
"RTW\n"
"Thu 20\n"
"08:00 - 16:00\n"
"RTW\n"
"Fri 21\n"
"08:00 - 16:00\n"
"RTW\n"
"Sat 22\n"
"OFF\n"
"Sun 23\n"
"OFF\n"
"Mon 24\n"
"OFF\n"
"Tue 25\n"
"04:40 -\n"
"13:07\n"
"5180\n"
"KM+\n"
"Wed\n"
"26\n"
"04:11\n"
"-\n"
"12:22\n"
"5178\n"
"Thu 27\n"
"10:00 - 18:00\n"
"Work.Group\n"
"Scheduling &\n"
"Rostering 1300-\n"
"1500 @Burwood...\n"
"Fri 28\n"
"OFF\n"
"Sat 29\n"
"NTA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")