re = /([A-Za-z]{3}\s[0-9]{1,2})\s?([0-9]{2}:[0-9]{2})?(?:\s?-\s?([0-9]{2}:[0-9]{2}))?\s?.*?(?=\n(Mon|Tue|Wed|Thu|Fri|Sat|Sun)\s[0-9]|$)/
str = 'Sun 16
08:00 -
16:00
RTW
Mon 17
08:00 - 16:00
RTW
Tue 18
08:00 -16:00
RTW
Wed 19
08:00 -
16:00
RTW
Thu 20
08:00 - 16:00
RTW
Fri 21
08:00 - 16:00
RTW
Sat 22
OFF
Sun 23
OFF
Mon 24
OFF
Tue 25
04:40 -
13:07
5180
KM+
Wed
26
04:11
-
12:22
5178
Thu 27
10:00 - 18:00
Work.Group
Scheduling &
Rostering 1300-
1500 @Burwood...
Fri 28
OFF
Sat 29
NTA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end