#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[\[).*(?=\]\])"
Local $sString = ": [[Bertus Aafjes]] (1914–1993), NL" & @CRLF & _
": [[Jeppe Aakjær]] (1866–1930), DK" & @CRLF & _
": [[Johannes Aal]] (um 1500–1551), CH" & @CRLF & _
": [[Hans Aanrud]] (1863–1953), NO" & @CRLF & _
": [[Emil Aarestrup]] (1800–1856), DK" & @CRLF & _
": [[Soazig Aaron]] (* 1949), FR" & @CRLF & _
": [[Ivar Aasen]] (1813–1896), NO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")