package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+(\s+Street)`)
var str = `Allatoona was a town located in extreme southeastern Bartow Street, Georgia.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}