$re = '/\w+(\s+Street)/';
$str = 'Allatoona was a town located in extreme southeastern Bartow Street, Georgia.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);