re = /\w+(\s+Street)/
str = 'Allatoona was a town located in extreme southeastern Bartow Street, Georgia.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end