#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{8,12}\b"
Local $sString = "e5655558888" & @CRLF & _
"r666666" & @CRLF & _
"t 5987442510" & @CRLF & _
"j69698888885" & @CRLF & _
"U 568457562388 11255525h555h4 4444444444444444 5655555/85 55555-555-23-23 55 This next section I do NOT want to be captured 636363666-66-12345678" & @CRLF & _
"I56588895620" & @CRLF & _
"56854444002 this number can be anywhere in the sentence ike this: 123456789 Or it could just be like this 98765432 these are good" & @CRLF & _
"but it should NOT find this 050860404-01e0-4a5a-b8db-a97f26a668ac" & @CRLF & _
"p 63666900000" & @CRLF & _
"bank account 12356895555" & @CRLF & _
"123456780000" & @CRLF & _
"2222" & @CRLF & _
"05086040" & @CRLF & _
"Not sure what the plan might be thought for when i have a sentence with account information for my checking account written in a document like this, here is the savings account number 1234567890. thank you. overdraft 9876543210"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")