package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{8,12}\b`)
var str = `e5655558888
r666666
t 5987442510
j69698888885
U 568457562388 11255525h555h4 4444444444444444 5655555/85 55555-555-23-23 55 This next section I do NOT want to be captured 636363666-66-12345678
I56588895620
56854444002 this number can be anywhere in the sentence ike this: 123456789 Or it could just be like this 98765432 these are good
but it should NOT find this 050860404-01e0-4a5a-b8db-a97f26a668ac
p 63666900000
bank account 12356895555
123456780000
2222
05086040
Not sure what the plan might be thought for when i have a sentence with account information for my checking account written in a document like this, here is the savings account number 1234567890. thank you. overdraft 9876543210`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}